Question about testing by running "xrun.scr"

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
mc2128
Posts: 7
Joined: March 4th, 2014, 9:06 am
Registered HYSPLIT User: Yes

Question about testing by running "xrun.scr"

Postby mc2128 » March 4th, 2014, 9:24 am

I installed hysplit and to insure the installation I ran the "xrun.scr".
However, in dispersion results, output was slightly difference with the "results.pdf" and some of them are very different.
For example, in page 16 of "results.pdf", there is "Dispersion using Deformation (012)" is obviously different with the "xrun.scr" output result.
I assume that this happened because of version difference or the "differences in random number generation on various hardware/software platforms" which mentioned in 'https://hysplitbbs.arl.noaa.gov/viewtopic.php?f=12&t=64'.
Can I get some advise about this problem?

Thank you for reading.

ariel.stein
Posts: 519
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Question about testing by running "xrun.scr"

Postby ariel.stein » March 19th, 2014, 8:58 am

Can you please send me page 16 of your results.pdf file? Also, what is the version you installed?

mc2128
Posts: 7
Joined: March 4th, 2014, 9:06 am
Registered HYSPLIT User: Yes

Re: Question about testing by running "xrun.scr"

Postby mc2128 » March 20th, 2014, 12:54 am

My hysplit version is
Last Changed Rev: 576
Last Changed Date: 2014-03-04 21:38:05 +0900 (Tue, 04 Mar 2014)

and pdf file version is 6 August 2013, Revision 515.

[The extension jpg has been deactivated and can no longer be displayed.]



Here is a difference.

ariel.stein
Posts: 519
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Question about testing by running "xrun.scr"

Postby ariel.stein » March 20th, 2014, 9:55 am

Your differences are only due to a change in the plotting contour routine.
If you slightly modify the xrun.scr as follows:

REM ------------------------
ECHO 'TITLE^&','Dispersion using Deformation (012)^&' >LABELS.CFG
COPY SETUP.012 SETUP.CFG
%PGM%\hycs_std 012
REM ---change here !!
%PGM%\concplot -icdump_012 -oplot_012.ps -v1e-12+1e-13+1e-14+1e-15
REM %PGM%\concplot -icdump_012 -oplot_012.ps
REM ----

DEL LABELS.CFG CONC.CFG SETUP.CFG MESSAGE.012 VMSDIST.012
TYPE plot_012.ps >>results.ps

you should get the same answer.

mc2128
Posts: 7
Joined: March 4th, 2014, 9:06 am
Registered HYSPLIT User: Yes

Re: Question about testing by running "xrun.scr"

Postby mc2128 » March 21st, 2014, 9:57 pm

Thank you for reply.

The color problem is now solved but, as you can see in the picture I uploaded there is some kinds of differences in the picture.
(some colored region apeared SE in the pdf but not in results.ps)

Why this happened?

ariel.stein
Posts: 519
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Question about testing by running "xrun.scr"

Postby ariel.stein » March 24th, 2014, 9:48 am

That is because you are using 3 dimentional lagrangian particles that have a finite mass. If your concentration plot labels are low enough you will always see some structure in the concentrations. If you add more particles that structure should be less evident.


Return to “HYSPLIT for LINUX”

Who is online

Users browsing this forum: No registered users and 1 guest