VCRUNTIME140.dill was not found

Post any questions or comments regarding the Desktop PC version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to include the operating system you are using (Windows XP, Windows Vista, Windows 7, Windows 8, etc.
Post Reply
Mujuni
Posts: 7
Joined: April 6th, 2020, 10:12 am
Registered HYSPLIT User: Yes

VCRUNTIME140.dill was not found

Post by Mujuni » April 10th, 2020, 4:56 am

Hello everyone,

I install HYSPLIT and its graphical utilities Tcl/Tk and other supporting interfaces. However, I can't run the code because when I click the HYSPLIT icon to open, it give me the error message written "The code execution cannot proceed because VCRUNTIME140.dill was not found. Reinstalling the program may fix this problem."
I reported this problem to the developer and I was advised to download and install vc_redist.x64.exe from Microsoft. I did as per those instructions i.e downloaded and installed but without success. I am still facing the same problem. So any one who can help me is highly appreciated.

Kindly see the error message in the attachment herewith.
Attachments
Error Message.docx
(29.57 KiB) Downloaded 20 times

sonny.zinn
Posts: 37
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: VCRUNTIME140.dill was not found

Post by sonny.zinn » April 13th, 2020, 6:57 am

Last year, I had the same error with a laptop running Windows 7. It was resolved by installing Microsoft Visual C++ 2015 Redistributable Update 3 RC from https://www.microsoft.com/en-us/downloa ... x?id=52685. Probably, your computer needs to be rebooted after installing the Redistributable.

Mujuni
Posts: 7
Joined: April 6th, 2020, 10:12 am
Registered HYSPLIT User: Yes

Re: VCRUNTIME140.dill was not found

Post by Mujuni » April 14th, 2020, 3:06 am

Thank you sonny.zinn for your response. It seems the solution you used to resolve the problem is the same solution I used. My laptop computer is windows 10, I am not sure if this might be a problem

sonny.zinn
Posts: 37
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: VCRUNTIME140.dill was not found

Post by sonny.zinn » April 14th, 2020, 6:21 am

I am not sure why the missing VCRUNTIM140.dll issue persists after you installed the Redistributables. I have a hysplit installation on my laptop which runs on Windows 10. Below is a screenshot of all installations of Microsoft Visual C++ Redistributables on the laptop. You might want to compare them with those on your computer.
List of MS C++ Redistributables
List of MS C++ Redistributables

Mujuni
Posts: 7
Joined: April 6th, 2020, 10:12 am
Registered HYSPLIT User: Yes

Re: VCRUNTIME140.dill was not found

Post by Mujuni » April 16th, 2020, 9:41 am

Hello sonny.zinn, thank you very much for your cooperation. I succeeded to solve the problem by installing the Microsoft Visual C++2015 Redistributable (x86). The one which I installed before (which did not solve the problem) was Microsoft Visual C++2015 Redistributable (x64).

huangj1311
Posts: 5
Joined: September 25th, 2014, 7:04 pm
Registered HYSPLIT User: No

Re: VCRUNTIME140.dill was not found

Post by huangj1311 » May 20th, 2020, 9:36 pm

Mujuni,

Install x86 VCRuntime really helps me to solve the problem.

Thanks!

Post Reply