"Flooring effect" on mixing layer depth data generated from GDAS files

Topics about the HYSPLIT trajectory model.
Post Reply
junyanl
Posts: 3
Joined: August 14th, 2019, 9:47 am
Registered HYSPLIT User: Yes

"Flooring effect" on mixing layer depth data generated from GDAS files

Post by junyanl » August 14th, 2019, 4:47 pm

I found an interesting phenomenon regarding data generated by the trajectory function, namely, a “flooring effect” on “MIXDEPTH” data.

In data generated from “gdas1" meteorology files, at winter time, normally Nov to Jan(Or July in southern hemisphere) there is always a minimum threshold for mixing layer depth(250). At February, this effect usually disappear. However, if we were to use meteorology file of higher resolution, namely, the “gfs0p25” files, this flooring effect does not exist. And here are some graphs to illustrate my point.

The PDF is mixing layer depth distribution of Ulaanbaatar in winter generated by “gdas1” meteorology files. In these comparison graphs, “coarse data” are data from “gdas1” files, while “refined data” are from “gfs0p25” files.

Please let us know if there is anything we can do about this phenomenon and I hope this report can help you on future HYSPLIT update
Attachments
Four year Mixing layer ylim.pdf
(8.76 KiB) Downloaded 2 times
Ulaanbaatar winter comparison.png
MeyertonJuly.png

alicec
Posts: 150
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: "Flooring effect" on mixing layer depth data generated from GDAS files

Post by alicec » August 19th, 2019, 8:56 am

By default HYSPLIT does set a minimum mixing depth (150m or 250m depending on the version of HYSPLIT you are using).
Please see the documentation on why HYSPLIT uses this default.
https://www.ready.noaa.gov/hysplitusersguide/S625.htm
Mixed Layer Depth Computation

KMIXD is used to control how the boundary layer depth is computed. In addition as acting as a vertical lid to particle dispersion (advection is not affected), the mixed layer depth is also used to scale the boundary layer mixing coefficients and computing turbulent fluxes from wind and temperature profiles. The default is to use the value provided by the meteorological model through the input data set. The profile can also be used if available. The computation defaults to use temperature profiles if the mixed layer field is not available. Another option to use for testing is to replace the index value (0,1,2) with a value greater than 10. In this situation, that value will be used as the mixed layer depth and will be constant for the duration of the simulation.

0 = Use meteorological model MIXD if available (DEFAULT)
1 = Compute from the temperature profile
2 = Compute from the TKE profile
> = 10 use this value as a constant
KMIX0 is a related parameter that sets the minimum mixing depth. The default value is 150 meters and is related to the typical vertical resolution of the meteorological data. A resolution near the surface of 15 hPa is typical of pressure-level data files. This suggests that it is difficult to infer a mixed layer depth of less than 150 m (10 m per hPa) for most meteorological input data.

To over-ride the default:
Set kmix0=0 in the SETUP.CFG file.
OR
To set in the GUI go to Advanced/Configuration Setup/Concentration/Configure the Turbulence method (7):
set the Default minimum (m) to 0.

If the flooring effect still exists after you set KMIX0=0, then it is coming from the NWP model and not from HYSPLIT.
You could try setting kmixd=1 in the SETUP.CFG and see how calculating the mixing depth from the temperature profile makes a difference.
(In GUI go the the same menu as for setting kmix0 and pick the "From temperature profile" radio button.

Let us know how it goes.

junyanl
Posts: 3
Joined: August 14th, 2019, 9:47 am
Registered HYSPLIT User: Yes

Re: "Flooring effect" on mixing layer depth data generated from GDAS files

Post by junyanl » August 19th, 2019, 3:01 pm

Thank you very much for your comment. After I made the changes in Hysplit GUI, the flooring effect went away. However, I realized running Hysplit with shell command is far more efficient and that's what i have been trying to do with R language. I'm pretty new to this and has a lot to figure out. Could you let me know how to change the default setting in SETUP.CFG without GUI? Because each time I manually change the 'kmix0' value in "SETUP.CFG" and run the program again, it gets overwritten and the value goes up to 250 again. Any suggestion is appreciated. Thank you!

alicec
Posts: 150
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: "Flooring effect" on mixing layer depth data generated from GDAS files

Post by alicec » August 20th, 2019, 7:55 am

The tutorial contains some help and many examples for scripting runs.
https://ready.arl.noaa.gov/documents/Tu ... batch.html

Post Reply