Ex. 16 Issue - Simulation stopped

Post Reply
RickV
Posts: 44
Joined: June 21st, 2020, 2:47 pm
Registered HYSPLIT User: Yes

Ex. 16 Issue - Simulation stopped

Post by RickV »

I have checked my editing efforts of EMITIMES & CONTROL files in the working directory. Perhaps one question here. That is, should first line of data read:

2010 04 14 00 36 24 (i.e., 36 replaces all (4) digits to give 36, not 0036 as shown below - more compact representation)

or

2010 04 14 00 0036 24 (i.e, if 36 replaces just the 12 -> 0036; 24 replaces 8 -> 24)

I did not commit the oversight Roland did - I changed 2 -> 6 before adding additional instructions to CONTROL.

After launching HySPLIT via hycs_std in Command Prompt window (64-bit Win7 Pro) I obtained this after Last Changed Date line:
Enter starting time (year, month, day, hour
0 0 0 0

Can you help me diagnose my issue?
aring
Posts: 32
Joined: June 12th, 2020, 7:04 am
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by aring »

Hi there,
Can you provide your CONTROL, SETUP, MESSAGE and EMITIMES files used for this simulation?
Thank you!
RickV
Posts: 44
Joined: June 21st, 2020, 2:47 pm
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by RickV »

Of course. The files you requested are attached...I was required to convert these to *.txt in order to attach them.
Attachments
MESSAGE.txt
(81.14 KiB) Downloaded 46 times
EMITIMES.txt
(1.45 KiB) Downloaded 43 times
CONTROL.txt
(683 Bytes) Downloaded 46 times
aring
Posts: 32
Joined: June 12th, 2020, 7:04 am
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by aring »

Can you attach the SETUP.CFG file as well? Thank you!
RickV
Posts: 44
Joined: June 21st, 2020, 2:47 pm
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by RickV »

I did but it dies not seem to result in being attached to my post. Trying again...worked.
Attachments
SETUP.txt
(683 Bytes) Downloaded 44 times
aring
Posts: 32
Joined: June 12th, 2020, 7:04 am
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by aring »

The message file your provided says the simulation completed normally so I don't think this is the message file for this simulation.

Regardless, I used your emitimes file and control file along with my setup file, and the simulation ran smoothly.
The spacing of the 00 36 or 0036 does not matter. It is better to keep it in the format shown on the first line of the emitimes file:
YYYY MM DD HH DURATION(hhhh) #RECORDS
So I would use 0036.

As for your other issue, it may be that the executable cannot find the appropriate files. Be sure you are in the /hysplit/working directory before running the ../exe/hycs_std executable.
Also, be sure the CONTROL file does not have a ".txt" at the end.

Another option is to ensure all of your files have the same extension so they are grouped together:
Screen Shot 2020-06-25 at 1.01.49 PM.png
As you can see, I added the extension RickV to all of my input files and file designations (cdump, pardump, emitimes, setup, control). Now all files associated with this run have the extension RickV. IF you do this, please be sure to change the names of ALL the files in your setup and control files.
If you do this, you run the model by typing this in the command line:
Screen Shot 2020-06-25 at 12.53.56 PM.png
As you can see, the simulation runs correctly.
RickV
Posts: 44
Joined: June 21st, 2020, 2:47 pm
Registered HYSPLIT User: Yes

Re: Ex. 16 Issue - Simulation stopped

Post by RickV »

Thank you. You identified my error. I was not in the working directory when I launched hysplit.
Post Reply

Return to “16. Volcanic eruptions with gravitational settling”