GSView requesting for verification code

yannima6
Posts: 1
Joined: February 17th, 2021, 2:47 am
Registered HYSPLIT User: Yes

GSView requesting for verification code

Post by yannima6 »

Hello everyone, I reread the tutorial page of HYSPLIT (link: https://www.ready.noaa.gov/documents/Tu ... l_win.html ). At section 3 it denoted
Ghostscript can be used in place of GSview, but may require a change to the directory location of where HYSPLIT looks for Ghostview (see Section 5 below).
and section 5
If Ghostscript is used in place of GSview, you may be required to change the directory location of where HYSPLIT looks for Ghostview in the "Set Directories" GUI menu under the Advanced/Configuration Setup tab. Set it to the same location and executable name (gswin64.exe) as Ghostscript.
After doing so, I tried to display it again and find this really works! Hope this can help you.
gws
Posts: 10
Joined: February 19th, 2016, 7:05 pm
Registered HYSPLIT User: No

Re: GSView requesting for verification code

Post by gws »

I have the same issue since installing HYSPLIT 5.1, after previously using 4.2 ...

When I execute the plot routine, gsview says it cannot find the DLLs, and I had no solution for that.
When I tried the solution of copying the ghostscript path to the ghostview path as indicated, I get an error message saying gsview is required ...

What should I try next?
gws
Posts: 10
Joined: February 19th, 2016, 7:05 pm
Registered HYSPLIT User: No

Re: GSView requesting for verification code

Post by gws »

We figured it out.
It is critical that NOT ghostscript version 9.54 is installed.
After reverting to versions 9.50 and making sure the directories are aligned, it worked again
sonny.zinn
Posts: 219
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: GSView requesting for verification code

Post by sonny.zinn »

That is great. We already had the information that Ghostscript 9.54 is incompatible: https://www.ready.noaa.gov/HYSPLIT_util.php. The sentence is now highlighted in red to readily catch attention.
lego007
Posts: 11
Joined: May 5th, 2021, 4:38 pm
Registered HYSPLIT User: Yes

Re: GSView requesting for verification code

Post by lego007 »

Hi,

I am having the same problem. I have the right version and re-install Hysplit, ghostscript 9.52, and ghostview 5.0. This is the error:

GSview 5.0 2012-01-17
Unknown in Comments section at line 4:
%%Created with: PSPLOT PostScript Plotting Package

Unknown in Comments section at line 5:
%%Library Creator: Kevin E. Kohler <kevin@ocean.nova.edu>

Failed to load C:\Program Files\Ghostgum\gs7.04\bin\gsdll64.dll, error 126
The specified module could not be found.

Failed to load C:\Program Files\Ghostgum\gsview\gsdll64.dll, error 126
The specified module could not be found.

Failed to load gsdll64.dll, error 126
The specified module could not be found.

Can't load Ghostscript DLL

Thanks
alicec
Posts: 328
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: GSView requesting for verification code

Post by alicec »

You can try using ghostscript in place of ghostview if you cannot get ghostview to work.
In the
advanced / set directories /
menu
you can point the ghostview path to point to ghostscript.
christopher.loughner
Posts: 66
Joined: August 15th, 2017, 3:59 pm
Registered HYSPLIT User: No

Re: GSView requesting for verification code

Post by christopher.loughner »

What OS are you using?

You could try using an older version. We tested GSview 5.0 with Ghostrscript 9.23 and 9.52.

As Roland mentioned, you can try using Ghostscript if you are having problems with Ghostview.

A user above mentioned that "after reverting to versions 9.50 and making sure the directories are aligned, it worked again"
lego007
Posts: 11
Joined: May 5th, 2021, 4:38 pm
Registered HYSPLIT User: Yes

Re: GSView requesting for verification code

Post by lego007 »

I believe to use ghostscript will work in place of ghostview but you will loose certain features in the ghostview (zoom, save, and print, etc.)

Do I need to install version 9.50 for ghostscript instead of 9.52?
lego007
Posts: 11
Joined: May 5th, 2021, 4:38 pm
Registered HYSPLIT User: Yes

Re: GSView requesting for verification code

Post by lego007 »

I am using window 10 (64). Hysplit is 5.0. What is "making sure the directories are aligned" means? Is it hysplit "exec" in default?
christopher.loughner
Posts: 66
Joined: August 15th, 2017, 3:59 pm
Registered HYSPLIT User: No

Re: GSView requesting for verification code

Post by christopher.loughner »

In the gui click on Advanced > Configuration Setup > Set Directories and check to see if the path to your ghostscript and/or ghostview paths are correct.

Not a big deal, but note that this workshop uses HYSPLIT 5.1.0, so you will get slightly different results for some of the examples that Roland will show if you use HYSPLIT version 5.0.0.

We had success with 9.23 and 9.52. A user above noted that they had success with 9.50.
Post Reply

Return to “2. Testing the installation”