error deleting "MESSAGE": permission denied

General questions and postings pertaining to the use of HYSPLIT regardless of the platform. For platform specific questions, use the HYSPLIT Platform forums.
ThomasPetrus
Posts: 1
Joined: June 17th, 2017, 5:48 pm
Registered HYSPLIT User: No

error deleting "MESSAGE": permission denied

Postby ThomasPetrus » June 17th, 2017, 5:55 pm

Hello all,

Recently I have started using HYSPLIT for a bachelor project at my university. However, after a couple of test runs I get the error message in my subject regardless of what I specify as input parameters/data. The full error code is as follows:

error deleting "MESSAGE": permission denied
error deleting "MESSAGE": permission denied
while executing
"file delete MESSAGE"
invoked from within
"if [file exists MESSAGE] {file delete MESSAGE}"
(procedure "Conc_run" line 11)
invoked from within
"Conc_run hycs_std S"
(menu invoke)

I am running an unregistered HYSPLIT version 854 on a Windows 10 PC, administrator account. At first the programme has worked well in producing some results, suggesting it is no longer part of the installation procedure. I personally think it has something to do with the removal/generation of files which HYSPLIT is not allowed by my PC, considering similar errors I have found online.

I hope this is an error message you know how to solve, because I have little time to generate results for my project (despite the requirements themselves being low).

Kind regards,

Thomas

alicec
Posts: 22
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: error deleting "MESSAGE": permission denied

Postby alicec » June 19th, 2017, 2:14 pm

Try the following:

Close out the GUI. Go to your working directory (in a standard installation this is C:\hysplit4\working).

Look for a file called MESSAGE. Delete it.

Open the GUI and try your run again.

If you continue to have problems with the GUI then try the following.

Setup your run in the GUI. After you have setup our run go to the concentration/ setup run tab.
Press the green SAVE as button on the bottom right corner.
save the file as CONTROL in your working directory (usually C:\hysplit4/working/CONTROL).
If you have changed anything in the Advanced menu then do the same thing only save the file as SETUP.CFg.

Then open a command prompt on your machine (I assume you are using a windows machine here).
type the following commands

cd C:\hysplit4\working
C:\hysplit4\exec\hycs_std

The first command brings you to the working directory where your CONTROL file is (and SETUP.CFG if you need one).
The second command runs hysplit.

If this works then the problem is with the GUI.

Let us know how it goes. If it still doesn't work then please post the contents of your CONTROl and SETUP.CFG files here.
As well as whatever is in the MESSAGE file.


Return to “Users”

Who is online

Users browsing this forum: No registered users and 1 guest