HYSPLIT Output MASS matter

Topics about the HYSPLIT dispersion model.
Post Reply
sol
Posts: 15
Joined: February 5th, 2020, 9:24 pm
Registered HYSPLIT User: No

HYSPLIT Output MASS matter

Post by sol »

Dear HYSPLIT Users
I used to running HYSPLIT Model to simulate Nuclear Power Plant accident.
I used kg/hr as a unit of emission rate.
I attached my default_conc below and i emphasize emission rate with Bold font and under line.

Code: Select all

19 07 23 01
1
35.41 126.42 50.0
96
0
10000.0
1
D:/G-CIEM_test/
0723_5DAY
1
C137
[b][u]4.65E+15[/u][/b]
96
19 07 23 01
1
35.88 127.5
0.03 0.05
5.6 5.0
D:/G-CIEM_test/
0723_5DAY_
1
0
19 07 23 01 00
19 07 27 01 00
00 12 00
1
0.4 1.9 1.0
0.002 136.96 0.0 0.0 0.0
0.0 3.2E+05 5.0E-05
10960.0
1.0E-06
I got Output result with kg/m2 unit and I calculated Output results to ensure total deposited mass is smaller than total amount of emission mass.
But I found that total deposited mass is larger than total amount of emission mass.
I attached calculation history below.

Code: Select all

Total deposited mass = Σ(Concentration of grid[kg/m2])*(grid area[m2])
Total emission mass = (Emission rate[kg/hr])*(emission duration[hr]) 
Here is the questions.
1. Are there any error or mistake in my mass calculation?
2. Why the situation that Total deposited mass is larger than Total emission mass, occur?
3. To calculate MASS BALANCE with HYSPLIT Result, what equation should i use? or Which section in the manual should i read?

And i also attached CONC.CFG and SETUP.CFG below.
CONC.CFG

Code: Select all

 &SETUP
 tratio = 0.75,
 initd = 0,
 kpuff = 0,
 khmax = 9999,
 kmixd = 0,
 kmix0 = 250,
 kzmix = 0,
 kdef = 0,
 kbls = 1,
 kblt = 0,
 conage = 48,
 numpar = -2500,
 qcycle = 0.0,
 efile = '',
 tkerd = 0.18,
 tkern = 0.18,
 ninit = 1,
 ndump = 0,
 ncycl = 0,
 pinpf = 'PARINIT',
 poutf = 'PARDUMP',
 mgmin = 10,
 kmsl = 0,
 maxpar = 10000,
 cpack = 1,
 cmass = 0,
 dxf = 1.0,
 dyf = 1.0,
 dzf = 0.01,
 ichem = 0,
 maxdim = 1,
 kspl = 1,
 krnd = 6,
 frhs = 1.0,
 frvs = 0.01,
 frts = 0.10,
 frhmax = 3.0,
 splitf = 1.0,
 /
SETUP.CFG

Code: Select all

 &SETUP
 tratio = 0.75,
 initd = 0,
 kpuff = 0,
 khmax = 9999,
 kmixd = 0,
 kmix0 = 250,
 kzmix = 0,
 kdef = 0,
 kbls = 1,
 kblt = 0,
 conage = 48,
 numpar = -2500,
 qcycle = 0.0,
 efile = '',
 tkerd = 0.18,
 tkern = 0.18,
 ninit = 1,
 ndump = 0,
 ncycl = 0,
 pinpf = 'PARINIT',
 poutf = 'PARDUMP',
 mgmin = 10,
 kmsl = 0,
 maxpar = 10000,
 cpack = 1,
 cmass = 0,
 dxf = 1.0,
 dyf = 1.0,
 dzf = 0.01,
 ichem = 0,
 maxdim = 1,
 kspl = 1,
 krnd = 6,
 frhs = 1.0,
 frvs = 0.01,
 frts = 0.10,
 frhmax = 3.0,
 splitf = 1.0,
 /
I need your help.
Thank you in advanced.
alicec
Posts: 281
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT Output MASS matter

Post by alicec »

Note that the deposition layer, unlike the concentration layers, shows the accumulated amount of mass/m^2.
https://www.ready.noaa.gov/documents/Tu ... m_dry.html

Another thing to check is how you are calculating the area of the grid square.
sol
Posts: 15
Joined: February 5th, 2020, 9:24 pm
Registered HYSPLIT User: No

Re: HYSPLIT Output MASS matter

Post by sol »

Thank you for your kind reply.

According to your reply, you said deposition layer indicate accumulated concentration. so i need to use last Output time result to calculate the total amount of mass in the deposition layer.
But i got another question about your advice.
By running the HYSPLIT model, I got 9 results(e.g. time1.asc, time2.asc, ...., time9.asc)
I reviewed whole results file and it doesn't seems 'time9.asc' file revealed accumulated deposition concentration,Σ(time1~9.asc),.
The reason that i think like above line is below.
In time9.asc file, there is no concentration value in specific spot which have value in another results file, such as time2.asc.

Does 'accumulated concentration',you mentioned on your reply, is accumulated concentration while time interval that i set to run the HYSPLIT model?
In that case, should i sum whole results file(e.g. time1.asc,...,time9.asc) and multiply area value to calculate total amount of deposition mass while total modeling duration?
alicec
Posts: 281
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT Output MASS matter

Post by alicec »

Yes - you are correct - my answer was not very clear and I'm going to delete it so as not to confuse future readers.
The deposition is accumulated over each time period.

Are you trying to emit 14.65e15 kg/hr for 96 hours?
That is what you have set.

It looks like you need to increase your MAXPAR.
Look at your MESSAGE file. You will see something that says
"warning emspnt: exceeding puff limit"

That means that you have reached the maximum number of particles that you set
and the model will not emit anymore. You have a maxpar = 10000 and numpar=-2500.
the numpar=-2500 means you want to emit 2500 particles per hour.
And you have the emission time set for 96 hours.

But since you have maxpar set at 10,000 you are running out of particles after 4 hours.
So your emissions are only lasting that long.

I'm not sure that this solves your issue - as you say that you are computing too much mass in the deposition field.
And this will decrease the amount of mass you are emitting over the 96 hours as you are only emitting over the first 4 hours.
sol
Posts: 15
Joined: February 5th, 2020, 9:24 pm
Registered HYSPLIT User: No

Re: HYSPLIT Output MASS matter

Post by sol »

I am really appreciate for your kind reply and your advice.
As you know, I faced on excced particle number warning for long time.
I tried to fix the MAXPAR value, But every time that i set MAXPAR larger than that i used, 'Exceed particle number limit' message keep appear.
I think it's because meteorological data that i used.

I've been using GFS0p25 global meteorological data file and I found that every particle that generated on simulation time counted until simulation end.
To run HYSPLIT model properly and to eliminate 'Excced particle number limit' message, What value of MAXPAR should i set?

Would you please check for me that my equation below which calculating MAXPAR correct?
I used simple equation, 'PARNUM * 96hrs =MAXPAR',.

Code: Select all

PARNUM : -1000
MAXPAR : 96000
...
alicec
Posts: 281
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT Output MASS matter

Post by alicec »

Please try the following.

1. The most important thing is to set the last line in your control file to 0. This option causes more particles to be generated and
is not recommended for most applications. For long runs, this option will very often cause maxpar to be exceeded.
https://ready.arl.noaa.gov/hysplitusersguide/S314.htm

2. If you are emitting for 96 hours and numpar=-2500 (the negative forces number of particles per hour rather than number of particles
per emissions cycle) then you will need maxpar = 96*2500 = 240000.
It's a good idea to make MAXPAR a little larger - MAXPAR = 300,000.

3. You many be able to reduce the number of particles you need in the following circumstances
a. If you use met data that is not global, then particles will be killed once they leave the area defined by the met data.
b. you can get rid of particles after they reach a certain age by setting KHMAX. https://ready.arl.noaa.gov/hysplitusersguide/S623.htm
c. you can get rid of particles with very small amount of mass by setting FRMR https://ready.arl.noaa.gov/hysplitusersguide/S630.htm
Post Reply