Page 1 of 2

an issue with running hycm_std

Posted: April 2nd, 2020, 4:22 pm
by itscd
I'm trying to calculate the pollutant concentrations using the parallel mode of hysplit (hycm_std) on a server and ran into an issue. I was able to initiate the model runs but after a minute they all stopped and gave me this error message:
"At line 224 of file depset.f (unit = 74, file = 'CONTROL')
Fortran runtime error: End of file
"

Does anyone know how i might fix this? This (https://www.dropbox.com/s/mgq8d75wm8ak5 ... G.002?dl=0) is the warning file created in the working directory in case that's helpful. Since i was running 30 parallel sessions, there are 30 files of these. But they are all the same.

Many thanks!

Re: an issue with running hycm_std

Posted: April 3rd, 2020, 6:27 am
by sonny.zinn
For the convenience of others, here is the full content of the WARNING.002 file in the previous post:

WARNING metini: FLUXES not found in data (kg,kt) 1 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 2 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 3 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 4 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 5 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 6 1
Setting KBLS=2 to use the wind/temp profiles!

Re: an issue with running hycm_std

Posted: April 5th, 2020, 11:45 pm
by itscd
I should have done this myself! Thanks for being so thoughtful!

Re: an issue with running hycm_std

Posted: April 6th, 2020, 11:27 am
by barbara.stunder
Since the error you first saw mentioned the CONTROL file, please check it. Did you try a simplified run (such as less duration, less number of particles) on the otherwise same CONTROL/SETUP files but running the regular hycs_std?

Re: an issue with running hycm_std

Posted: April 7th, 2020, 2:52 pm
by itscd
I tried and got the same error message
"At line 224 of file depset.f (unit = 74, file = 'CONTROL')
Fortran runtime error: End of file
"
However, since i was using hycs_std, only one such message was shown (instead of 30 in the previous run which was using hycm_std on 30 nodes).

Re: an issue with running hycm_std

Posted: April 9th, 2020, 4:29 pm
by barbara.stunder
Then it is probably an issue with the CONTROL file. Please post the CONTROL file.

Re: an issue with running hycm_std

Posted: April 11th, 2020, 1:10 am
by itscd
I realized i should have copied and pasted the text in the CONTROL file directly. So here it is:

05 05 20 04
1
57.6 -157.5 5000
1704
0
10000.0
6
/gpfs/data1/working/
NARR200505
/gpfs/data1/working/
NARR200506
/gpfs/data1/working/
NARR200507
/gpfs/data1/working/
NARR200508
/gpfs/data1/working/
NARR200509
/gpfs/data1/working/
NARR200510
1
TEST
9.91360416667e+12
24
5 5 21 04 00 00
1
63 -154
0.1 0.1
0 0
/gpfs/data1/working/
batch_2005_00001_V4_HPC
1
500
00 00 00 00 00
05 07 31 04 00
00 24 00
1
2.5 2 1
0.0 0.0 0.0 0.0 0.0
0.0 0.0 0.0
0.0

Re: an issue with running hycm_std

Posted: April 13th, 2020, 10:28 am
by barbara.stunder
There are 5 lines describing the pollutant deposition parameters but your CONTROL file only has 4. Probably by adding a 0.0 after your last line will solve it. See the File Formats at https://ready.arl.noaa.gov/hysplitusersguide/

Re: an issue with running hycm_std

Posted: April 13th, 2020, 2:20 pm
by itscd
Thanks for spotting that error. However, after i've fixed it, the same error persists. I'm still getting the error message
At line 224 of file depset.f (unit = 74, file = 'CONTROL')
Fortran runtime error: End of file

from the command line and
WARNING metini: FLUXES not found in data (kg,kt) 1 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 2 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 3 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 4 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 5 1
Setting KBLS=2 to use the wind/temp profiles!
WARNING metini: FLUXES not found in data (kg,kt) 6 1
Setting KBLS=2 to use the wind/temp profiles!

in the warning file.

Re: an issue with running hycm_std

Posted: April 14th, 2020, 3:45 pm
by alicec
You are also defining the span as 0.
https://ready.arl.noaa.gov/hysplitusersguide/S313.htm

0.1 0.1
0 0
/gpfs/data1/working/
batch_2005_00001_V4_HPC
1
500