HYSPLIT error

Topics about the HYSPLIT dispersion model.
Smaug
Posts: 31
Joined: July 1st, 2017, 8:28 am
Registered HYSPLIT User: No

Re: HYSPLIT error

Post by Smaug » May 14th, 2018, 6:20 am

Good Morning,

I have increased MAXPAR, varied KHMAX and decreased the grid size but I am still getting the same error:

It seems that the EMITIMES file can only have 10 days worth of releases unless I set KHAMX to be very small at which point the plume has barley left the release point. Ideally I want have a global grid and release over the entire month in my EMITIMES file.

I am running this on Linux which I compiled using the ifort compiler. I believe the version is HYSPLIT4 with the latest update on the 26th April 2017.

Thanks

alicec
Posts: 75
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT error

Post by alicec » May 14th, 2018, 10:11 am

I am not able to reproduce your error, even running with numpar=100000.
forrtl:error(69): process interrupted (SIGINIT)

Are you using the multi-processor hycm_std? or hycs_std?

It looks like the error is system dependent so it may take a bit to track down.

Can you please attach a MESSAGE file. The MESSAGE file may be PDF.
When is the program failing? Does it fail right when you
start HYSPLIT or at a particular time?

I didn't think changing any of those parameters would fix that error.
I just was pointing out that with those particular parameters, you will only be able to release particles
over 3 days (not 10).

So it is interesting that you can finish the run when KHMAX is small? How small does it have to be?

Alice

Smaug
Posts: 31
Joined: July 1st, 2017, 8:28 am
Registered HYSPLIT User: No

Re: HYSPLIT error

Post by Smaug » May 14th, 2018, 12:47 pm

Are you using the multi-processor hycm_std? or hycs_std?

I am using hycm_std with 4 threads.


Can you please attach a MESSAGE file. The MESSAGE file may be PDF.

I am in the process of getting this uploaded.

When is the program failing? Does it fail right when you
start HYSPLIT or at a particular time?


Around 40%.

I just was pointing out that with those particular parameters, you will only be able to release particles
over 3 days (not 10).


I decreased NUMPAR and increased MAXPAR to take that into account. When I truncate the releases from the 11th to the 21st it runs to finish. When I include the release on the 22nd it finishes to around 48% then it gives the error.


So it is interesting that you can finish the run when KHMAX is small? How small does it have to be?

I can't seem to get the parameter setup where it runs when KHMAX is small, maybe I was mistaken. So at the moment:

NUMPAR=100
MAXPAR=100000
KHMAX=24

EMITIMES goes from 11th to 22nd (it runs from 11th to 21st). Decreasing KHMAX (even to one) doesn't seem to help and the simulation seems to consistently terminate around 40% for above setup.

alicec
Posts: 75
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT error

Post by alicec » May 14th, 2018, 2:32 pm

If you are using hycm_std, I think your error message may be related to the stack size limit.

People running WRF seem to get this error. I haven't seen it with HYSPLIT before, but I don't think we have as many people using
the hycm_std version. Someone in the WRF forum suggested "ulimit -s unlimited" (or "export OMP_STACKSIZE=64m") before running the executable to avoid the error.

Please let us know if it works.

Also, to troubleshoot, try running with the single processor (hycs_std) and see if it works.

Alice

Smaug
Posts: 31
Joined: July 1st, 2017, 8:28 am
Registered HYSPLIT User: No

Re: HYSPLIT error

Post by Smaug » May 15th, 2018, 5:28 am

Using hycs_std doesn't give me an error message but it stops the simulation about the same time and prints "900" to the screen.

I've added the both the ulimit command and the export command to increase the stack size but I am still getting the forrtl:error(69): process interrupted (SIGINIT).

alicec
Posts: 75
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT error

Post by alicec » May 15th, 2018, 9:19 am

I think the next steps are:

1 Send me your MESSAGE files.

2 try compiling with gfortran and see if that makes a difference.

Smaug
Posts: 31
Joined: July 1st, 2017, 8:28 am
Registered HYSPLIT User: No

Re: HYSPLIT error

Post by Smaug » May 15th, 2018, 9:58 am

I've attached the first part of the MESSAGE file. Let me know if you need the rest.
Attachments
MESSAGE.pdf
(518.32 KiB) Downloaded 30 times

alicec
Posts: 75
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: HYSPLIT error

Post by alicec » May 15th, 2018, 4:27 pm

Yes. I need the whole MESSAGE file to see where it stopped running and if there are any warnings.
Also, could you please provide MESSAGE file for the hycs_std run.

Thanks.

Smaug
Posts: 31
Joined: July 1st, 2017, 8:28 am
Registered HYSPLIT User: No

Re: HYSPLIT error

Post by Smaug » May 16th, 2018, 10:11 am

I recompiled with gfortran and I am afraid I'm getting a similar error. If I add a single entry after the 21st I get:

STOP 900

printed to the screen. It runs if the emission go from 11th to 21st. If I keep on adding emission cycles in the EMITIMES then I get:

Segmentation fault - invalid memory reference.

I tried using the ulimit -s unlimited and hycs_std but that didn't help. I will upload the message file in my next post.

Post Reply