Gaussian/Top Hat model parameters

Topics about the HYSPLIT dispersion model.
Post Reply
rotendd
Posts: 22
Joined: September 25th, 2016, 12:16 pm
Registered HYSPLIT User: Yes

Gaussian/Top Hat model parameters

Post by rotendd » July 14th, 2017, 12:26 pm

Greetings,

I am trying to run a dispersion with a Gaussian/Top Hat model but one of two things goes wrong:

1.) I get a message in the WARNING file stating: "puff splitting turned off ... expand MAXPAR or increase merge parameters in CFG namelist file."

2.) After changing the Puff Split-Merge Options (Advanced/Configuration Setup/Concentration/Menus #4,5), the model runs but produces no output values.

I am new to the Gaussian/Top Hat model so I may be forgetting to set a parameter somewhere. I choose to use this model by going to Advanced/Configuration Setup/Concentration/Menu #3. I only choose option "Gaussian-horizontal TH - vertical puff" and run the model. (initd = 1 in the SETUP.CFG file) Is there an additional parameter somewhere that needs to be set?

The message file is attached. This message came from a run that finished with no apparent errors but the output was empty.

Any suggestions would be great! Thanks!

alicec
Posts: 56
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by alicec » July 17th, 2017, 9:27 am

I don't see your MESSAGE file. Please try to attach again.

The first message "puff splitting turned off.. expand MAXPAR or increase merge parameters in CFG namelist file" is not uncommon
when running with puffs, particularly if you are trying to do a longer run. This message simply means that puffs have split to the point where now you have the maximum number allowed (which is set by the maxpar setting). HYSPLIT will no longer split the puffs but it will keep propagating them forward.

A few tips:

- it is usually a good idea to have the puffs released per cycle be quite a bit smaller than the number you would use with particles. Check to make sure you are not releasing a lot of puffs to begin with.

-increasing puff merging might help you but it might not depending on the meteorological situation and how big an area the plume eventually covers.

-increasing maxpar could help (menu 4 maximum number of particles).

-consider whether you need puff in the vertical and horizontal. Try using puff in the horizontal only.

-if doing a long run consider converting back to particles after some time.

Why you are getting empty output when changing the split merge options is difficult to diagnose without knowing what options
you are using. Please attaché message file. CONTROL and SETUP.CFG files would also be helpful.

Cheers,
Alice

rotendd
Posts: 22
Joined: September 25th, 2016, 12:16 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by rotendd » July 18th, 2017, 3:25 pm

Oops! Let me try attaching again. These are the CONTROL, EMITIMES, and MESSAGE files from my latest run. I tried reducing the number of puffs emitted but it didn't help.

My latest error is in the MESSAGE file.

Thanks!
Attachments
MESSAGE.txt
(32.48 KiB) Downloaded 9 times
EMITIMES.txt
(331 Bytes) Downloaded 13 times
CONTROL.txt
(490 Bytes) Downloaded 11 times

alicec
Posts: 56
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by alicec » July 19th, 2017, 1:17 pm

I suggest you use initd=3 or 4 (horizontal puff and vertical particle)
And increase your maximum particle number (maxpar) to at least 100000 (you currently have 10000).

The warning is generated when puff splitting would generate more puffs than the maximum allowed (set by maxpar).
For some runs, continuous puff splitting is just not feasible due to finite computational resources.
That is why we provide options to go from puff to particle mode after some time.

rotendd
Posts: 22
Joined: September 25th, 2016, 12:16 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by rotendd » July 20th, 2017, 3:04 pm

Thanks for the advice! My overall goal is to model the emissions from a powerplant stack and incorporate the following:

  • All of the stacks present
  • The height of each stack
  • the diameter of each stack
  • the exit velocity (Briggs eqn method) of each stack
All for a 24 hour period.

To the best of my knowledge, the horizontal particle model DOES NOT incorporate an area emission (for stack diameter.) Hence, the use of a gaussian method.

1.) Is an area emission still incorporated in a hybrid method? (Gaussian horizontal, particle vertical)
2.) If I convert from gaussian to particle after 1 hour, will the emission area still be used and accurately represented?

Thanks VERY much again!

alicec
Posts: 56
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by alicec » July 21st, 2017, 9:16 am

When you use an area emission, the Gaussian or top-hot puff is initialized with a width that will cover that area.
This will occur for horizontal puff / vertical particle mode.
Converting to particles later in the simulation will not affect how the puff is initialized.

alicec
Posts: 56
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by alicec » July 21st, 2017, 11:40 am

A few other thoughts-

In the emitimes file you sent, you are using a stack height of 0.
You probably want to use the correct stack height.

Also, think about how big an effect specifying the area of the stack exactly will have.
You have the area of your stack as only 50m^2.
Think of this in comparison to your concentration grid which you have set
to 0.05 x 0.05 degrees. Since a degree is roughly 111 km, the area of your concentration
grid cell is about 30km^2
You can also think about it in comparison to the resolution of your meteorological data which is 12km (144km^2)

rotendd
Posts: 22
Joined: September 25th, 2016, 12:16 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by rotendd » July 21st, 2017, 1:22 pm

Your insights are very helpful!

In regards to the 0m stack height and the inclusion of stack area, something that I am interested in is how much these values can affect the output results after they have been propagated over a 24hr period. I'm incrementing these values for a handful of different power plants. This EMITIMES file is just one example of parameter values that I've used.

Thanks again!

rotendd
Posts: 22
Joined: September 25th, 2016, 12:16 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by rotendd » July 24th, 2017, 12:30 am

One other (hopefully) quick question...

If I use Gh-Pv to 3D particle (initd = 130) and set the conversion time to 0 hours (conage = 0), will a puff of my desired width in the EMITIMES file still be initialized but immediately converted to particles? Or will a value of conage = 0 cause HYSPLIT to run the model as a 1D point source?

Thanks!

alicec
Posts: 56
Joined: February 8th, 2016, 12:56 pm
Registered HYSPLIT User: Yes

Re: Gaussian/Top Hat model parameters

Post by alicec » July 24th, 2017, 12:00 pm

I would suggest you try the following things:

1 - do some sensitivity tests in which you initialize the model in various ways and see how different your results are.
For instance you can compare using just particles from a point to using puffs with some width and changing to particles after (1,2,6,8 hours).
Try using more and less particles and puffs.

2. If you decide you want to use just particles and you want to approximate some sort of area - just specify multiple point sources spread
out over the area that you want to approximate.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest