Compiling mer2arl issue and segmentation error

Post questions and find resources to convert meteorological data into a format HYSPLIT can read.
Post Reply
Posts: 2
Joined: September 12th, 2019, 11:56 am
Registered HYSPLIT User: No

Compiling mer2arl issue and segmentation error

Post by jrpreece »


I'm new to working in a shell environment, so please excuse the basic question. I've been having trouble successfully compiling and running the mer2arl program while working with the Ubuntu precompiled binaries. Initially, I tried compiling mer2arl using the Makefile that was included in the data2arl/mer2arl directory. That process seemed to complete without any issues; however, when trying to run the unaltered 'run.mer2arl.wget' script within the data2arl/mer2arl directory, I received an error stating that the .//mer2arl command could not be found:
Is it necessary to compile mer2arl when working with the Ubuntu precompiled binary? If so, should running the 'make' command generate a mer2arl executable within the data2arl/mer2arl directory?

I did find a mer2arl executable in the UbuntuDynamicExecutables/exec directory and tried pointing to that location when running the 'run.mer2arl.wget' script, but received the following segmentation error when doing so:
Thank you in advance for your time. I appreciate any help that you can offer.
Posts: 118
Joined: November 8th, 2012, 3:41 pm

Re: Compiling mer2arl issue and segmentation error

Post by Fantine »

You can use the precompiled mer2arl executable in ~/exec directory. Check if you have all the required libraries installed and linked. Instructions about this are in README_external_libraries.txt.

If you compile the program in ~/data2arl/mer2arl directory yourself, the Makefile should be modified by providing the path of the netcdf library (NETLIB and NETINC). The executable "mer2arl" is written in ~/exec directory unless you change the Makefile to put it somewhere else. It seems the mer2arl you used is not the precompiled one.
Post Reply