MERRA2 dataset

Post questions and find resources to convert meteorological data into a format HYSPLIT can read.
Post Reply
Posts: 111
Joined: November 8th, 2012, 3:41 pm

MERRA2 dataset

Post by Fantine »

A conversion program is now available to convert MERRA2 files to ARL format for HYSPLIT application. It is in the trunk/data2arl/mer2arl directory and is called mer2arl.

A readme file (Readme_mer2arl.txt) is available in the directory.
The required library is netCDF version 4.
An example csh script (run.mer2arl.wget) for downloading the MERRA files is available in the directory.
The converter processes data on native model levels and takes variables from four input files.

MERRA2 is a global dataset with spatial resolution in 0.6x0.5 degree and 3-hour temporal resolution. There are 72 native model levels from the surface to 0.01 hPa. The downloading web page is (registration required).
Posts: 1
Joined: November 22nd, 2017, 3:28 pm
Registered HYSPLIT User: No

Re: MERRA2 dataset

Post by adezfuli »

Is this going to be available for PC and Mac as well? Thanks!
Posts: 7
Joined: November 9th, 2017, 12:13 pm
Registered HYSPLIT User: Yes

Re: MERRA2 dataset

Post by acollow »

Thanks for making a conversion program available for MERRA-2! I already have MERRA-2 data and do not need to run the wget script, however it is on a -180 to 180 grid as opposed to 0 to 360. I tried to modify mer2arl.f by commenting out the following section:
! do ii=1,nxp
! idx=ii-289+1
! if (idx .le. 0) idx=nxp+idx
! base(ii,:)=cnv2dv(n)*var2d(idx,:) ! swtich to 0-360 system, ii=289 at a grid point longitude=0

! if (TRIM(label) .eq. 'phis') WRITE(LUNIT,*) ii,idx
! end do

I am not sure if it is related but now when I run mer2arl.f, I get errors saying "NetCDF: Index exceeds dimension bound". Was this the only part of the code that needed to be modified for the different longitudes?

Post Reply