Error when downloading archived met plots

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
j.boehms
Posts: 4
Joined: January 12th, 2016, 6:54 pm
Registered HYSPLIT User: No

Error when downloading archived met plots

Post by j.boehms » January 12th, 2016, 7:06 pm

I am trying to download Archived NAMs files. I have had success in the past but for some reason I keep getting the same error now. No idea what it means or why it is happening. I am somewhat new to Linux and Hysplit so any help would be greatly appreciated!

Application Error:
------------------------------------------------------------------------
Not connected.
Local directory now /home/hysplit/hysplit/trunk/working
Not connected.
Not connected.
Interactive mode off.
Not connected.
ftp: connect: Connection timed out
Not connected.
Local directory now /home/hysplit/hysplit/trunk/working
Not connected.
Not connected.
Interactive mode off.
Not connected.
ftp: connect: Connection timed out
while executing
"exec ftp -n $ftparc(0) << $input"
invoked from within
"if [catch {package require ftp} rcode] {
if [info exists input] {unset input}
append input "user anonymous $Password\n"
append input..."
(procedure "ftp_cdata" line 27)
invoked from within
"ftp_cdata"
invoked from within
".getarc.bot.save invoke"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list $w invoke]"
(procedure "tk::ButtonUp" line 22)
invoked from within
"tk::ButtonUp .getarc.bot.save"
(command bound to event)
-------------------------------------------------------------------------

ariel.stein
Posts: 612
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Error when downloading archived met plots

Post by ariel.stein » January 13th, 2016, 10:38 am

The error you are getting is because we have changed the location of the NAMs files in our ftp server. You can find the files at
ftp://arlftp.arlhq.noaa.gov/nams/
In the next release of the GUI we will fix this problem. In the mean time you can directly download the files using your web browser and saving the files your working directory.

ariel.stein
Posts: 612
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Error when downloading archived met plots

Post by ariel.stein » January 13th, 2016, 10:54 am

I just checked our GUI and we have already made that change. I am not sure what is causing your problem but first try downloading the files directly from the ftp server. If that work we can explore other options to solve your problem.

j.boehms
Posts: 4
Joined: January 12th, 2016, 6:54 pm
Registered HYSPLIT User: No

Re: Error when downloading archived met plots

Post by j.boehms » January 13th, 2016, 7:47 pm

Thank you for the response. I went to the website and tried to download the files directly, however I need data from 2008, specifically, April-July. The files at ftp://arlftp.arlhq.noaa.gov/nams/ only went back to March of 2009, even though the GUI on Hysplit indicates NAMs files are available for >=2008.

I went ahead and downloaded the unregistered version of Hysplit onto my Windows PC to see if I could get the files that way (thinking it was a Linux problem), but I still got the same error using the PC version. When the error occurred an image popped up (see image link below) which leads me to believe its a problem with Tcl/Tk, which might explain why I get the error on both platforms (Linux and Windows).

Image
https://plus.google.com/u/0/10176611528 ... 9543234031

From there I selected both boxes and allowed access but I still was unable to download the NAMs files. I tried reinstalling the ActiveTcl8.6.4 with no success and then I even tried installing the ActiceTcl8.5.18.0 version and still no luck.

ariel.stein
Posts: 612
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Error when downloading archived met plots

Post by ariel.stein » January 14th, 2016, 10:18 am

It seems we do not have NAMs data before March 22, 2009.

Post Reply