Page 1 of 1

arw2arl not found

Posted: November 24th, 2015, 3:15 am
by caiwenyi

I have successfully installed HYSPLIT per the execution of xrun.scr and viewing , but when I tried convert WRF file to arl , I got an error

message : Can't execvp ../exec/arw2arl : No Such file or directory

Then , I took a look under the "exec" directory , and the "arw2arl" really didn't exist.

Could you please give me some hints how to solve this? please help me!!!

Re: arw2arl not found

Posted: November 24th, 2015, 9:09 am
by ariel.stein
go to data2arl/arw2arl/
However, to compile this program you will need to have NetCDF compiled and installed with the same compiler as the one you used for hysplit.

Re: arw2arl not found

Posted: November 27th, 2015, 6:40 am
by caiwenyi
Yes,I have compiled this program,and then I went to exec , the 'arw2arl' has existed.

But when I tried convent WRF file to arl

/nuist/scratch/Caiwenyi0507/hysplit/ -i/nuist/scratch/Caiwenyi0507/15you/wrfout_09060800 -o/nuist/scratch/Caiwenyi0507/123/wrf2arl_090608.bin

Then I got some error message:/nuist/scratch/Caiwenyi0507/hysplit/ symbol lookup error: /nuist/p/public/app/netcdf/4.3.0/pgi/11.7-0/lib/ undefined symbol: ncopts

any help would be greatly appreciated.

Re: arw2arl not found

Posted: December 1st, 2015, 8:40 am
by ariel.stein
Make sure you use the same version of the fortran compiler for arw2arl and the netcdf libraries.