Hysplit install won't create "hysplit4.tcl"

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
kcking
Posts: 3
Joined: July 13th, 2015, 3:39 pm
Registered HYSPLIT User: Yes

Hysplit install won't create "hysplit4.tcl"

Post by kcking » July 13th, 2015, 3:45 pm

Hi all,

I'm trying to install hysplit on Yellowstone and I have been following the tutorial instructions for the install located here: https://ready.arl.noaa.gov/documents/Tu ... _unix.html. I am now getting through the entire installation/compile.sh file except for the last 3 lines. When it tries to link to the "hysplit4.tcl" file in ../guicode, the file is not there. I cannot figure out where in the installation process this file is created and why it is not being created. I do have TCL (I can run wish) and everything is correctly pointing to the NETCDF directories. I even ran "xrun.scr" and didn't have any problems except that it is not compiled for multiple processors. Has anyone else run into this error?

Thanks so much for any help!

ariel.stein
Posts: 623
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Hysplit install won't create "hysplit4.tcl"

Post by ariel.stein » July 14th, 2015, 2:30 pm

That is really strange. Are you sure there is no hysplit4.tcl file in the guicode directory?
Did you run the update.sh script to get the latest version of the code?

kcking
Posts: 3
Joined: July 13th, 2015, 3:39 pm
Registered HYSPLIT User: Yes

Re: Hysplit install won't create "hysplit4.tcl"

Post by kcking » July 14th, 2015, 6:35 pm

Yes, there is definitely no hysplit4.tcl anywhere. I've run a "find" and couldn't locate that file. There are many other *.tcl files in the guicode and working directories.

I ran update.sh last week, but would prefer not to run it again because I will have to go through and change all the netCDF and compilers again. Also, I compiled using intel compilers (e.g., ifort). Should I go back and use the gnu compilers?

glenn.rolph
Posts: 336
Joined: November 7th, 2012, 1:39 pm
Registered HYSPLIT User: Yes
Contact:

Re: Hysplit install won't create "hysplit4.tcl"

Post by glenn.rolph » July 15th, 2015, 6:42 am

Attached is a copy of the hysplit4.tcl (it was renamed to hysplit4.txt to enable the upload so you will have to rename it).
Attachments
hysplit4.txt
(21.67 KiB) Downloaded 161 times

kcking
Posts: 3
Joined: July 13th, 2015, 3:39 pm
Registered HYSPLIT User: Yes

Re: Hysplit install won't create "hysplit4.tcl"

Post by kcking » July 16th, 2015, 5:47 pm

Thank you! That worked!

Post Reply