Questions about running''runarw.sh'' and ''hysplit.tcl''

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
xmhxy
Posts: 1
Joined: May 20th, 2014, 10:23 pm
Registered HYSPLIT User: Yes

Questions about running''runarw.sh'' and ''hysplit.tcl''

Post by xmhxy » June 30th, 2014, 11:38 pm

When I run ''runarw.sh'', the screen showed:

NetCDF: Variable not found
X
Variable not found: X
NetCDF: Variable not found
X
Variable not found: X
Some defined variables not found in file: .//wrfout_d01_2014-02-11_00:00:00
Edit WRFDATA.CFG and try again ...
cat: ARLDATA.BIN: No such file or directory
Using an existing decoding configuration: WRFDATA.CFG


When I checked my "WRFDATA.CFG", it showed:

num3dv = 7,
arw3dv = 'P','T','U','V','W','X','QVAPOR',
cnv3dv = 0.01, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0,
arl3dv = 'PRES','TEMP','UWND','VWND','WWND','DIFW','SPHU',
num2dv = 12,
arw2dv = 'HGT','PSFC','RAIN','X','PBLH','UST','SWDOWN','HFX','LH','T2','U10','V10',
cnv2dv = 1.0, 0.01, 0.001, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0,
arl2dv = 'SHGT','PRSS','TPP1','DIFR','PBLH','USTR ','DSWF','SHTF','LHTF','T02M','U10M','V10M',


What does "X" mean?​
After I used ''QRAIN'' and ''RAINC'' or ''TKE_MYJ'' and ''ZNT'' to replace ''X'', or just delete ''X'', the ''runarw.sh'' could run successfully.
But I want to know how many variables are need to run the ''runarw.sh'' actually, and what are they specifically??
If I use random variable, does it have bad influence to the result ''WRFRAIN.BIN''??

Also what bothered me is weather my result ''WRFRAIN.BIN'' is right for the next step, which is the running of ''./hysplit.tcl/Trajectory/Run model''.
Every time when I used ''WRFRAIN.BIN'' to run hysplit, the simulation log showed:

Model started ...
At line 139 of file metset.f
Fortran runtime error: Bad value during integer read
HYSPLIT4 - Initialization
USE: svn info | tail -n3
to fill in these three records
with the version information!


How to solve these problem??
Thanks so much for reading and be grateful if you can solve my problem!!!!

ariel.stein
Posts: 623
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Questions about running''runarw.sh'' and ''hysplit.tcl''

Post by ariel.stein » July 18th, 2014, 9:33 am

Please try using the following configuration (WRFDATA.CFG):
&SETUP
num3dv = 6,
arw3dv = 'P','T','U','V','W','QVAPOR',
cnv3dv = 0.01, 1.0, 1.0, 1.0, 1.0, 1.0,
arl3dv = 'PRES','TEMP','UWND','VWND','WWND','SPHU',
num2dv = 12,
arw2dv = 'HGT','PSFC','RAIN','PBLH','UST','ZNT','SWDOWN','HFX','LH','T2','U10','V10',
cnv2dv = 1.0, 0.01, 0.001, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0,
arl2dv = 'SHGT','PRSS','TPP1','PBLH','USTR','RGHS ','DSWF','SHTF','LHTF','T02M','U10M','V10M',
/


Also, the file that you need to use for your run is ARLDATA.BIN, not WRFRAIN.BIN

Post Reply