Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
KMAUT
Posts: 2
Joined: June 15th, 2020, 1:54 am
Registered HYSPLIT User: Yes

Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by KMAUT »

I've downloaded the hysplit 5 distribution for Ubuntu (hysplit.v5.0.0_Ubuntu) and installed the prerequisites and dependencies (I think), but cannot install HYSPLIT. I tried following the tutorial here https://ready.arl.noaa.gov/documents/Tu ... _unix.html but when I run make I get a "No rule to make target" error. On further reading it seems using the distribution should mean I don't need to compile? But I can't find instructions on how to use the distribution. Based on a question from an earlier user I tried to run the hysplit.tcl file in /working but (although tcl is installed) when I try to run it with tclsh I get an error:

~/Downloads/hysplit.v5.0.0_Ubuntu/working$ tclsh hysplit.tcl@
couldn't read file "hysplit.tcl@": no such file or directory

Although I can see the file listed there (in light blue). I'm a beginner in Ubuntu, any help would be greatly appreciated.

Thank you
sonny.zinn
Posts: 90
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by sonny.zinn »

Steps 2 to 6 in section "1.3 UNIX - LINUX HYSPLIT install" are applicable only when HYSPLIT is built from the source code. Since you are using a pre-compiled distribution, those sections are inapplicable.

To run hysplit, as described in Step 7, first change directory to the working directory. Then execute ../guicode/hysplit.tcl.
KMAUT
Posts: 2
Joined: June 15th, 2020, 1:54 am
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by KMAUT »

Hello,

Thanks for taking the time to respond. Apologies, as I'm new I need a little more guidance. I've gone into the HYSPLIT folder, and tried to execute hysplit.tcl but I'm getting the error below. I'm not sure if I'm using the wrong command to execute - or if there is something else I'm doing wrong? I also tried the which xterm command in step 7 but I don't get a response with that (I don't know if I'm using a X window or not of course so that may not matter).

katie@katie-HP-EliteBook-850-G3:/usr/local/bin/hysplit.v5.0.0_Ubuntu/guicode$ tclsh hysplit.tcl*
invalid command name "winfo"
while executing
"winfo child ."
invoked from within
"eval destroy [winfo child .]"
(file "hysplit.tcl" line 51)

Thanks again
jazz
Posts: 3
Joined: September 19th, 2020, 7:36 am
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by jazz »

enter "./hysplit.tcl" in command prompt.
i.e. command prompt: $ ./hysplit.tcl
a gui interface will pop up.
I spent whole day to do make and "failed"... :(
sonny.zinn
Posts: 90
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by sonny.zinn »

It might be helpful to review steps 7 and 8 at https://www.ready.noaa.gov/documents/Tu ... _unix.html. If the hysplit.tcl symbolic link does not exist in your "hysplit/working" directory, it should be created as described in step 7.
jazz
Posts: 3
Joined: September 19th, 2020, 7:36 am
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by jazz »

I can open the guicode ./hysplit.tcl.
the gui pop up.
However, the fortran library cannot be loaded which I try to run the model...

../exec/hyts_std: error while loading shared libraries: libgfortran.so.5: cannot open shared object file: No such file or directory
Which text file should I edit so my library can be redirected correctly?

Where is the complete guide for ubuntu setup?
jazz
Posts: 3
Joined: September 19th, 2020, 7:36 am
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by jazz »

I can run the guicode -> ./hysplit.tcl.
However, when I try to run the model, the library of gfortran was not found...
../exec/hyts_std: error while loading shared libraries: libgfortran.so.5: cannot open shared object file: No such file or directory
seem there are so many missing step for ubuntu release.
where is the complete guide for ubuntu setup?
Thanks.
sonny.zinn
Posts: 90
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: Problem installing HYSPLIT 5 on ubuntu 18.04.4

Post by sonny.zinn »

gfortran may not have been installed on your Ubuntu. Please have gfortran installed and try it again.
Post Reply