Precompiled binary compatibility

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
murray
Posts: 3
Joined: December 6th, 2019, 4:43 am
Registered HYSPLIT User: Yes

Precompiled binary compatibility

Post by murray »

Hi,

I am trying to use the precompiled Linux binary sets for the latest HYSPLIT release available on the website, and am having some issues with the Red Hat/CentOS versions.

Whilst I can get the Red Hat 6 version to work on a machine running CentOS 6, both the Red Hat 6 and CentOS 7 versions crash with segmentation faults every time when running on a CentOS 7 machine. Does anyone have any suggestions/advice on getting these to work? I have all the prerequisite libraries installed.

Also, is there a version available which is compatible with the latest Ubuntu LTS release (18.04)? The version available on the website states it is built with 18.10, which is an interim release now out of support.


Thanks for the help!

Murray
murray
Posts: 3
Joined: December 6th, 2019, 4:43 am
Registered HYSPLIT User: Yes

Re: Precompiled binary compatibility

Post by murray »

For anyone else that may encounter this: the Ubuntu 18.10 version can be run on 18.04; you will just need to ensure that GCC 8 is available on the PATH (prior to the system install, which is 7)
Post Reply