Testing compiled code.

Post any questions or comments regarding the LINUX version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to mention the version of LINUX you are using.
Post Reply
HWZealot
Posts: 8
Joined: August 26th, 2017, 8:54 am
Registered HYSPLIT User: Yes

Testing compiled code.

Post by HWZealot » August 26th, 2017, 9:23 am

Hi,
I downloaded the code from SVN server, and compiled it using intel fortran compiler (change the FC in makefile to ifort).
The version I use is 896.
When compiling, everything seems to be okay and there was no error. After running compile.sh, I run ./testing/xrun.scr and produced results.ps in /testing folder. The running process didn't produce error.
But when I compared with Results_v854.pdf, it seems that the Trajectory is much the same, but Dispersion Simulation figure seems to be different.
I don't know if that means my program is wrongly compiled? Or is there any other way to confirm the correctness?
Thank you in advance.

ariel.stein
Posts: 642
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Testing compiled code.

Post by ariel.stein » August 28th, 2017, 9:26 am

Small concentration changes are expected due to differences in the compilers and processors.
Can you please share with us your results.ps file?

HWZealot
Posts: 8
Joined: August 26th, 2017, 8:54 am
Registered HYSPLIT User: Yes

Re: Testing compiled code.

Post by HWZealot » August 29th, 2017, 8:17 am

Thanks for replying.
Here are the 010 result from two versions of ./xrun.scr. (the whole results are too big to upload as attachment).
One is using Intel FORTRAN compiler 17.0, the other one is using pgfortran 16.10c.
Most result are like this one, with very little different.
Attachments
010_sample_result_v854.png
010_pgfortran_16.10c.png
010_ifort_17.0.png

HWZealot
Posts: 8
Joined: August 26th, 2017, 8:54 am
Registered HYSPLIT User: Yes

Re: Testing compiled code.

Post by HWZealot » August 29th, 2017, 8:19 am

Follow up.
But a few results, for example 510, are very different and even not appear on the sample result pdf.
Attachments
510_pgfortran_16.10c.png
510_ifort_17.0.png

HWZealot
Posts: 8
Joined: August 26th, 2017, 8:54 am
Registered HYSPLIT User: Yes

Re: Testing compiled code.

Post by HWZealot » August 29th, 2017, 8:23 am

Also,here is the 012 result.

By the way, because I'm new to SVN revision control, is the whole hysplit program in the ./trunk folder?
Thank you.
Attachments
012_sample_result_v854.png
012_pgfortran_16.10c.png
012_ifort_17.0.png

ariel.stein
Posts: 642
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Testing compiled code.

Post by ariel.stein » August 29th, 2017, 10:12 am

That is completely normal. The different compilers produce slightly different calculations because they produce different random number generators that are used to calculate the turbulent dispersion in the model.
Also, you notice that the plotting program sometimes chooses different contours depending on the calculated values. The contours can be fixed if needed.
Bottom line, your results are perfectly acceptable.

HWZealot
Posts: 8
Joined: August 26th, 2017, 8:54 am
Registered HYSPLIT User: Yes

Re: Testing compiled code.

Post by HWZealot » August 30th, 2017, 1:46 am

Thanks a lot for help. :)
One more question, are all the HYSPLT application in ./trunk folder? I'm not very familiar with SVN project structure, so just to make sure this.

ariel.stein
Posts: 642
Joined: November 7th, 2012, 3:14 pm
Registered HYSPLIT User: Yes
Contact:

Re: Testing compiled code.

Post by ariel.stein » August 30th, 2017, 3:04 pm

Yes

Post Reply