problems with anaconda/python install for HYSPLIT

Post any questions or comments regarding the Desktop PC version of HYSPLIT. This includes the model execution, GUIs, results, or graphics. Be sure to include the operating system you are using (Windows XP, Windows Vista, Windows 7, Windows 8, etc.
Post Reply
lesnow93
Posts: 2
Joined: January 18th, 2021, 12:30 pm
Registered HYSPLIT User: No

problems with anaconda/python install for HYSPLIT

Post by lesnow93 »

Dear HYSPLIT support,

I'm working through the June 2020 tutorial material and I hit a snag when I got to the portion using python display examples.
I backed up and installed the hysplit environment in my PC's anaconda build, which all seemed to go well until I ran the tests for hysplitplot. FYI, the tests passed right away for hysplitdata.

Pretty much all the python test files failed in hysplitplot due to a common import error, it appears:

_________________________________________ ERROR collecting tests/test_util.py _________________________________________
ImportError while importing test module 'C:\hysplit\python\hysplitplot\tests\test_util.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
test_util.py:16: in <module>
from hysplitplot import util, const
..\hysplitplot\__init__.py:2: in <module>
from .conc.plot import ConcentrationPlot
..\hysplitplot\conc\plot.py:24: in <module>
from hysplitplot import cmdline, const, datem, mapbox, mapproj, \
..\hysplitplot\plotbase.py:16: in <module>
from hysplitplot import cmdline, const, labels, logo, multipage, \
..\hysplitplot\streetmap.py:13: in <module>
import geopandas
C:\Users\jlcase\Anaconda3\envs\hysplit\lib\site-packages\geopandas-0.4.1-py3.7.egg\geopandas\__init__.py:1: in <module>
from geopandas.geoseries import GeoSeries
C:\Users\jlcase\Anaconda3\envs\hysplit\lib\site-packages\geopandas-0.4.1-py3.7.egg\geopandas\geoseries.py:12: in <module>
from geopandas.base import GeoPandasBase, _series_unary_op, _CoordinateIndexer
C:\Users\jlcase\Anaconda3\envs\hysplit\lib\site-packages\geopandas-0.4.1-py3.7.egg\geopandas\base.py:6: in <module>
from pandas.core.indexing import _NDFrameIndexer
E ImportError: cannot import name '_NDFrameIndexer' from 'pandas.core.indexing' (C:\Users\jlcase\Anaconda3\envs\hysplit\lib\site-packages\pandas-1.2.0-py3.7-win-amd64.egg\pandas\core\indexing.py)


Do you have any recommendations on how I can proceed with hysplitplot at this point?

Thanks much,
Jonathan Case
sonny.zinn
Posts: 89
Joined: May 8th, 2019, 1:31 pm
Registered HYSPLIT User: Yes

Re: problems with anaconda/python install for HYSPLIT

Post by sonny.zinn »

Downgrading pandas to 1.0.1 may work. For details, see viewtopic.php?p=6248#p6248.
lesnow93
Posts: 2
Joined: January 18th, 2021, 12:30 pm
Registered HYSPLIT User: No

Re: problems with anaconda/python install for HYSPLIT

Post by lesnow93 »

Hello,

I solved my problem yesterday. There was an error in the file "pkgs_win10.txt" in that the list of packages was missing pandas altogether.
I added the following line to that file, re-built the hysplit environment, and then all worked well.

https://repo.anaconda.com/pkgs/main/win ... 7a_0.conda

Regards,
Jonathan
Post Reply