Page 1 of 1

Single Particle Animation Error

Posted: December 11th, 2019, 1:37 pm
by bektas61
Hi, everyone,
I have a question about Single Particle Animation.
To see all the frames in a single animated graphic, similar to a trajectory, pressed the Concentration / Utilities / Postscript to Image menu tab to open the ImageMagick conversion menu. I selected the Animate button as in attachment1 and the ı clicked to execute the conversion button. After
I got this error message attachment2

child killed: unknown signal
child killed: unknown signal
while executing
"exec $magick_pgm -quiet -density $Density -loop 100 -delay 30 -dispose Background $Input_file $Output_file"
(procedure "run_magick" line 34)
invoked from within
invoked from within
" invoke"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list $w invoke]"
(procedure "tk::ButtonUp" line 24)
invoked from within
(command bound to event)

When ı tried to solve it by myself after reading the help menu
I opened the configuration setup/Set directories I realized that ImageMagick path/executable included only convert.exe as attacment3 and ı determined the pathway of ImageMagick
as --> C:/Program Files/ImageMagick-7.0.8-Q16/convert.exe

I got the same error. I wonder what is the solution of this error?
I m looking forward to your answers. Thanks for your time.
Best regards,

Re: Single Particle Animation Error

Posted: December 16th, 2019, 10:41 am
by barbara.stunder
Are you saying you got the same error with both of the following in the "Set Directories"?
C:/Program Files/ImageMagick-7.0.8-Q16/convert.exe

Try it again after exiting the GUI and restarting it, and make sure the Set Directories has the full path (C:/Program...).

Did you verify the postscript file is correct?

Re: Single Particle Animation Error

Posted: December 16th, 2019, 2:24 pm
by McP82
I'm not the original author of the thread, but I can confirm that restarting the GUI and making sure that the full path is indicated works.

Re: Single Particle Animation Error

Posted: December 20th, 2019, 10:09 am
by bektas61
Yes, I am saying I got the same error both of the following in the "Set directories"
C:/Program Files/ImageMagick-7.0.8-Q16/convert.exe (attacment4)
It is tried as your descriptions but the result did not change. yes the postscript file is ""
But ı read more things in the help menu as below
""In the rare situation when this file cannot be edited or does not exist because the GUI did not load because of problems with Tcl/Tk, then the appropriate lines in the upper-level Tcl/Tk file ..\guicode\hysplit4.tcl need to be changed. For instance, the lines that might require editing would be similar to the following: set magick_dir "c:/Program Files (x86)/ImageMagick-6.4.4-Q8/convert.exe"
set gsc_dir "c:/Program Files (x86)/gs/gs8.63/bin/gswin32.exe"
set gsv_dir "c:/Program Files/Ghostgum/gsview/gsview32.exe" ""

Then I opened hysplit4.tcl file under guicode and realized that There no line starts with "set gsc_dir" instead of it start with set gsc_pgm. Moreover It continuous with ""/usr/local/ImageMagick-6.1.5/bin/convert" despite mine "ImageMagick-7.0.8-Q16" as (attachment5). Maybe, it is correct or not ı don't but ı can explain the situation like this way as ı understood.

I m looking forward to your answers. Thank you.

Re: Single Particle Animation Error

Posted: December 23rd, 2019, 10:49 am
by barbara.stunder
I meant did you verify is as expected? Did you view it and all the images are ok?

In Notepad, open the file C:\hysplit4\working\default_exec. When you went in "Set Directories" through the GUI, that is the file that you are changing. Verify it has
C:/Program Files/ImageMagick-7.0.4-Q16/convert.exe
or wherever it is installed on your computer.

You can also manually edit default_exec instead of editing it in the GUI.

That section of hysplit4.tcl you attached is in the unix section, but aren't you running in Windows?

One more thing to try - In the Tutorial section on Single Particle Animation ... _view.html
click on the "C:\ gear" icon at the top. That gives the Windows/DOS commands. Near the bottom is the "convert" command. Copy and paste that into the Command Prompt window in c:\hysplit\working (directory where is). That may give a more understandable error message. [In Windows search bar enter "Command Prompt", then do "C:", then "cd hysplt4\working" then paste the convert command.

Re: Single Particle Animation Error

Posted: December 25th, 2019, 8:42 am
by McP82
Wait, there was a tutorial to begin with? Thanks, I'll make sure to study it, we're using Hysplit for our research where I study, but we've never received any formation about how to use it apart from what the professors tell us, and it's a significant loss of time to ask about everything...

Re: Single Particle Animation Error

Posted: December 26th, 2019, 3:49 pm
by bektas61
Thanks Barbara It was solved. The problem caused by installation issues.

I would install to imagemagick program before the ghostview. that was the reason why it did not read the postscript file and
convert it as .gif file.
It was installed different way to show differeces.

you know sometimes starting with begining of the task could be beneficial.
I am much obliged for your help that worked to find source of the problem :)